T-Mobile Officially Acknowledges HSPA+ Issue With 4G HTC Handsets

Earlier today T-Mobile staff started a new thread in their support forum polling users for reports of unusually short battery life starting over the past week.

Hello everyone,
A small group of T-Mobile customers are noticing battery drain. As of around July 28, 2011, their phones haven’t been holding their charge as well as they used to.

We’re working aggressively to resolve this issue, but if a you find that the battery drains more quickly than it has in the recent past (starting around July 28th), or phone is not holding a charge like it was, please reply here with the following information:

Device Make & Model
Start date on the issue
Where are you located (Market, City, State)?
Are you in a 2G, 3G or 4G area?
When battery indicator shows ‘No Power’ does the device still work or is the power drained?
Does “3G only mode” improve the battery drain issue?

Thank you to everyone for helping us out with your examples!

As of this moment 80 people have responded, including myself.

It’s curious that they refer to “3G only mode” as the G2 at least doesn’t have such a mode. The related setting in my G2 is labeled as “Use only 2G networks.”

Sorry for the blurry photo. That’s what sometimes happens when I take a handheld shot and defeat the flash.

Like everyone else responding in the forum, we have found that enabling this setting drops the phone to the EDGE network, and restores battery life to an acceptable norm.

At least with this acknowledgement there can be the expectation of some action toward solving the issue. Maybe they can even inform their customer service staff, who have been handling the matter haphazardly for the past week.